Support Center

Unsupported Browser

Last Updated: Mar 12, 2013 03:47PM EDT

Due to a large number of security and performance problems some older browsers (notably Internet Explorer 6 and 7) are no longer supported by Zistle. As a result of this, if you are using an older browser Zistle may function poorly or not at all for you. We want you to be able to use Zistle quickly and safely so we encourage you to update your web browser to something more modern.

There are a variety of options including Internet Explorer 8+, Chrome, Firefox or Safari. For more information about how to pick a new browser see Browser-Update.org

If you do not have administrative privileges on your machine and thus can’t upgrade your browser, you should attempt to install Chrome Frame.

If you have any questions feel free to file a ticket with support and we will try to help.

help@zistle.com
http://assets1.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete